summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-04-12 14:03:32 +0200
committerLuca Boccassi <luca.boccassi@gmail.com>2021-04-12 21:28:23 +0100
commit7c5fd25119a495009ea62f79e5daec34cc464628 (patch)
treec0f7e84be87060b4068f65eb38a03a70fe4ed10d /man/meson.build
parent72ae959efd01d306033f40d49e7ff515083f85f9 (diff)
downloadsystemd-7c5fd25119a495009ea62f79e5daec34cc464628.tar.gz
meson: do not fail if rsync is not installed with meson 0.57.2
https://github.com/mesonbuild/meson/issues/8641 Our CI started to fail. Even if the change is reverted in meson, we need a quick workaround here.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build25
1 files changed, 14 insertions, 11 deletions
diff --git a/man/meson.build b/man/meson.build
index 3cae8446cd..f9c4b83dc8 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -184,17 +184,20 @@ html = custom_target(
depends : html_pages,
command : ['echo'])
-run_target(
- 'doc-sync',
- depends : man_pages + html_pages,
- command : ['rsync', '-rlv',
- '--delete-excluded',
- '--include=man',
- '--include=*.html',
- '--exclude=*',
- '--omit-dir-times',
- meson.current_build_dir(),
- get_option('www-target')])
+rsync = find_program('rsync', required : false)
+if rsync.found()
+ run_target(
+ 'doc-sync',
+ depends : man_pages + html_pages,
+ command : [rsync, '-rlv',
+ '--delete-excluded',
+ '--include=man',
+ '--include=*.html',
+ '--exclude=*',
+ '--omit-dir-times',
+ meson.current_build_dir(),
+ get_option('www-target')])
+endif
############################################################