summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-02-28 13:06:52 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-02-28 13:10:08 +0100
commit9e083598642f041d591a10858efb40ab1ec8414d (patch)
tree8e12196a22ffb259bc986bbf91c0c34d53242cd1 /man/meson.build
parent358fb6862bf141f48965b130289ddbcd96400e61 (diff)
downloadsystemd-9e083598642f041d591a10858efb40ab1ec8414d.tar.gz
meson: remove workaround for old meson bug with command quoting
Those bugs were fixed a long time ago. Let's take advantage of this and use the usual $() syntax.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build5
1 files changed, 1 insertions, 4 deletions
diff --git a/man/meson.build b/man/meson.build
index 05197d6ef4..6956f39c7b 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -198,12 +198,9 @@ if git.found()
custom_target(
'update-man-rules',
output : 'update-man-rules',
- # slightly strange syntax because of
- # https://github.com/mesonbuild/meson/issues/1643
- # and https://github.com/mesonbuild/meson/issues/1512
command : ['sh', '-c',
'cd @0@ && '.format(meson.build_root()) +
- 'python3 @0@/tools/make-man-rules.py `git ls-files ":/man/*.xml"` >t && '.format(meson.source_root()) +
+ 'python3 @0@/tools/make-man-rules.py $(git ls-files ":/man/*.xml") >t && '.format(meson.source_root()) +
'mv t @0@/rules/meson.build'.format(meson.current_source_dir())],
depend_files : custom_entities_ent)
endif