summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-17 19:48:20 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-23 21:47:29 -0400
commita923e085af00dfd47eafbbd6964398a10e5a4f19 (patch)
treeb502f3c8562f198b7263c675a684968df86c5333 /man/meson.build
parent1aec3ed90d553482918b283e52b82918d7f5a388 (diff)
downloadsystemd-a923e085af00dfd47eafbbd6964398a10e5a4f19.tar.gz
meson: use run_target instead of custom_target where appropriate
This way a fake output does not need to be specified.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build43
1 files changed, 22 insertions, 21 deletions
diff --git a/man/meson.build b/man/meson.build
index 1c1dbd86b7..79d7710d11 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -130,24 +130,25 @@ foreach tuple : [['systemd.directives', '7', systemd_directives_xml],
html_pages += [p2]
endforeach
-man = custom_target('man',
- depends : man_pages,
- output : 'man',
- command : ['echo'])
-
-html = custom_target('html',
- depends : html_pages,
- output : 'html',
- command : ['echo'])
-
-custom_target('doc-sync',
- depends : [man, html],
- output : ['doc-sync'],
- command : ['rsync', '-rlv',
- '--delete-excluded',
- '--include=man',
- '--include=*.html',
- '--exclude=*',
- '--omit-dir-times',
- meson.current_build_dir(),
- get_option('www-target')])
+man = run_target(
+ 'man',
+ depends : man_pages,
+ command : ['echo'])
+
+html = run_target(
+ 'html',
+ depends : html_pages,
+ output : 'html',
+ command : ['echo'])
+
+run_target(
+ 'doc-sync',
+ depends : man_pages + html_pages,
+ command : ['rsync', '-rlv',
+ '--delete-excluded',
+ '--include=man',
+ '--include=*.html',
+ '--exclude=*',
+ '--omit-dir-times',
+ meson.current_build_dir(),
+ get_option('www-target')])