summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-07-08 15:14:46 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-07-16 12:36:44 +0200
commitb75077875194a4a9cf2f8e1fe869be673e40d8fb (patch)
treebccbcce304fc2b192717a3efce2e0e599e6e84f2 /man/meson.build
parent3c775de6c590679c3de37adb09c3e3e9c0de8028 (diff)
downloadsystemd-b75077875194a4a9cf2f8e1fe869be673e40d8fb.tar.gz
meson: allow systemd.directives and .index to be built if -Dman=false
See 559d215b6733bb46533a52080522a7feca183aa8 for justification.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/man/meson.build b/man/meson.build
index ec05d73bc6..fe19268bcd 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -117,8 +117,8 @@ systemd_index_xml = custom_target(
output : 'systemd.index.xml',
command : [make_man_index_py, '@OUTPUT@'] + nonindex_xml_files)
-foreach tuple : want_man or want_html ? [['systemd.directives', '7', systemd_directives_xml],
- ['systemd.index', '7', systemd_index_xml]] : []
+foreach tuple : xsltproc.found() ? [['systemd.directives', '7', systemd_directives_xml],
+ ['systemd.index', '7', systemd_index_xml]] : []
stem = tuple[0]
section = tuple[1]
xml = tuple[2]