summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2023-03-03 14:54:21 +0900
committerYu Watanabe <watanabe.yu+github@gmail.com>2023-03-03 19:56:38 +0900
commitd2ec38e2b2d7baa374ffbd0f81f1183e78ce1ca6 (patch)
tree825250755149d8ebe528d54e4ac33005def842f3 /man/meson.build
parent26ab5ea69d7b7804d0e9a7f4773443902c76c654 (diff)
downloadsystemd-d2ec38e2b2d7baa374ffbd0f81f1183e78ce1ca6.tar.gz
meson: rename conflicting target names
The update-man-rules and update-dbus-docs targets are both declared in the main meson.build and man/meson.build, so we cannot build the target with 'meson compile' command: ==== $ meson compile update-man-rules INFO: autodetecting backend as ninja ERROR: Can't invoke target `update-man-rules`: ambiguous name.Add target type and/or path: - ./man/update-man-rules:custom - ./update-man-rules:run ==== Let's rename the targets declared in man/meson.build.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/man/meson.build b/man/meson.build
index b7725ce5f0..23819d03f5 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -218,7 +218,7 @@ configure_file(
############################################################
update_dbus_docs = custom_target(
- 'update-dbus-docs',
+ 'update-dbus-docs-impl',
output : 'update-dbus-docs',
command : [update_dbus_docs_py, '--build-dir', project_build_root, '@INPUT@'],
input : dbus_docs)
@@ -232,7 +232,7 @@ if conf.get('BUILD_MODE_DEVELOPER') == 1
endif
update_man_rules = custom_target(
- 'update-man-rules',
+ 'update-man-rules-impl',
output : 'update-man-rules',
command : [update_man_rules_py,
'@0@/man/*.xml'.format(project_source_root),