summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authoruserwithuid <userwithuid@gmail.com>2017-08-09 13:41:44 +0000
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-08-09 09:41:44 -0400
commite85a690b9606a98a8ba8c02fa50a38d26a313f4b (patch)
tree66ccc3846993da19404d9f061371b6f6c33a64e9 /man/meson.build
parent4429c69f8da0c9ea892541a50d5c5f4ac1b42767 (diff)
downloadsystemd-e85a690b9606a98a8ba8c02fa50a38d26a313f4b.tar.gz
build-sys: fix invalid args detected by meson 0.42 (#6561)
some run_target() calls were using params from custom_target() example message: WARNING: Passed invalid keyword argument "input". This will become a hard error in the future. New way to call targets: ninja man/man ninja man/html ninja man/update-man-rules
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/man/meson.build b/man/meson.build
index a93693c43c..8ddbd5557c 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -170,10 +170,10 @@ man = custom_target(
depends : man_pages,
command : ['echo'])
-html = run_target(
+html = custom_target(
'html',
- depends : html_pages,
output : 'html',
+ depends : html_pages,
command : ['echo'])
run_target(
@@ -191,8 +191,9 @@ run_target(
############################################################
if git.found()
- run_target(
+ custom_target(
'update-man-rules',
+ output : 'update-man-rules',
# slightly strange syntax because of
# https://github.com/mesonbuild/meson/issues/1643
# and https://github.com/mesonbuild/meson/issues/1512