summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-05-09 13:23:50 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-05-09 18:17:28 +0200
commite9bbff18e1cb7fc2ec209255c523780ad2e3dfce (patch)
treeca351c185e3020a99e7e6a8963e921b1d0c05d72 /man/meson.build
parentda35a1c9fc94d9803d48332371033baca581de70 (diff)
downloadsystemd-e9bbff18e1cb7fc2ec209255c523780ad2e3dfce.tar.gz
meson: add build/man/man and build/man/html to build and display pages
Man page generation is generally very slow. I prefer to use -Dman=false when developing systemd, and only build specific pages when introducing changes. Those two little helper tools make it easy: $ build/man/man systemd.link $ build/man/html systemd.link will show systemd.link.8 and systemd.link.html from the build directory build/.
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/man/meson.build b/man/meson.build
index ae9c941fcd..f3992b2834 100644
--- a/man/meson.build
+++ b/man/meson.build
@@ -204,3 +204,15 @@ if git.found()
'mv t @0@/rules/meson.build'.format(meson.current_source_dir())],
depend_files : custom_entities_ent)
endif
+
+############################################################
+
+configure_file(
+ input : 'man.in',
+ output : 'man',
+ configuration : substs)
+
+configure_file(
+ input : 'html.in',
+ output : 'html',
+ configuration : substs)