summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaan De Meyer <daan.j.demeyer@gmail.com>2023-01-19 13:14:29 +0100
committerDaan De Meyer <daan.j.demeyer@gmail.com>2023-01-20 13:55:11 +0100
commit09595fd5f2afbcf2b71f9788049bd2d7a8a1248f (patch)
treeb56e3cd539de1346f510169de0393af11ceabbb3 /meson.build
parenta6a9ee4b36ae42e4d70f39e5e39e28f539f156e8 (diff)
downloadsystemd-09595fd5f2afbcf2b71f9788049bd2d7a8a1248f.tar.gz
ukify: Downgrade required python version to 3.9
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/meson.build b/meson.build
index 965b237d23..d37f47d48b 100644
--- a/meson.build
+++ b/meson.build
@@ -1976,13 +1976,13 @@ if run_command(python, '-c', 'import jinja2', check : false).returncode() != 0
error('python3 jinja2 missing')
endif
-python_310 = run_command(python, '-c',
- 'import sys; sys.exit(0 if sys.version_info >= (3,10) else 1)',
- check : false).returncode() == 0
+python_39 = run_command(python, '-c',
+ 'import sys; sys.exit(0 if sys.version_info >= (3,9) else 1)',
+ check : false).returncode() == 0
if get_option('ukify') == 'auto'
- want_ukify = python_310 and conf.get('HAVE_GNU_EFI') == 1
-elif get_option('ukify') == 'true' and (not python310 or conf.get('HAVE_GNU_EFI') != 1)
- error('ukify requires Python >= 3.10 and GNU EFI')
+ want_ukify = python_39 and conf.get('HAVE_GNU_EFI') == 1
+elif get_option('ukify') == 'true' and (not python_39 or conf.get('HAVE_GNU_EFI') != 1)
+ error('ukify requires Python >= 3.9 and GNU EFI')
else
want_ukify = get_option('ukify') == 'true'
endif