summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2023-02-01 10:05:36 +0100
committerGitHub <noreply@github.com>2023-02-01 10:05:36 +0100
commit2584e16cb7da5ac28bce3eb6ad3c001709b71346 (patch)
tree50d50d8e34d231d0aeb3031f8ecc6bc7e6d3f794 /meson.build
parent0e8330262e9fe081c80347a1b3badf649ed75857 (diff)
parentc49ac355c088be892012d82576f6a34d5acbca25 (diff)
downloadsystemd-2584e16cb7da5ac28bce3eb6ad3c001709b71346.tar.gz
Merge pull request #26236 from medhefgo/meson-fixes
meson: Fixes
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 3 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index de3cd660f1..a856bb2f84 100644
--- a/meson.build
+++ b/meson.build
@@ -184,7 +184,6 @@ sysctldir = prefixdir / 'lib/sysctl.d'
binfmtdir = prefixdir / 'lib/binfmt.d'
modulesloaddir = prefixdir / 'lib/modules-load.d'
networkdir = rootprefixdir / 'lib/systemd/network'
-pkgincludedir = includedir / 'systemd'
systemgeneratordir = rootlibexecdir / 'system-generators'
usergeneratordir = prefixdir / 'lib/systemd/user-generators'
systemenvgeneratordir = prefixdir / 'lib/systemd/system-environment-generators'
@@ -316,7 +315,6 @@ conf.set10('FIRST_BOOT_FULL_PRESET', get_option('first-
#####################################################################
cc = meson.get_compiler('c')
-pkgconfig = import('pkgconfig')
meson_build_sh = find_program('tools/meson-build.sh')
want_tests = get_option('tests')
@@ -1091,12 +1089,9 @@ else
if clang_found
clang = r.path()
endif
- # Assume that the required flags are supported by the found clang.
- clang_supports_flags = clang_found
else
clang_found = true
clang = cc.cmd_array()
- clang_supports_flags = cc.has_argument('-Wno-compare-distinct-pointer-types')
endif
if clang_found
@@ -2107,7 +2102,7 @@ install_libudev_static = static_library(
if conf.get('HAVE_LIBCRYPTSETUP_PLUGINS') == 1
if conf.get('HAVE_TPM2') == 1
- cryptsetup_token_systemd_tpm2 = shared_library(
+ shared_library(
'cryptsetup-token-systemd-tpm2',
cryptsetup_token_systemd_tpm2_sources,
include_directories : includes,
@@ -2125,7 +2120,7 @@ if conf.get('HAVE_LIBCRYPTSETUP_PLUGINS') == 1
endif
if conf.get('HAVE_LIBFIDO2') == 1
- cryptsetup_token_systemd_fido2 = shared_library(
+ shared_library(
'cryptsetup-token-systemd-fido2',
cryptsetup_token_systemd_fido2_sources,
include_directories : includes,
@@ -2143,7 +2138,7 @@ if conf.get('HAVE_LIBCRYPTSETUP_PLUGINS') == 1
endif
if conf.get('HAVE_P11KIT') == 1
- cryptsetup_token_systemd_pkcs11 = shared_library(
+ shared_library(
'cryptsetup-token-systemd-pkcs11',
cryptsetup_token_systemd_pkcs11_sources,
include_directories : includes,