summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFranck Bui <fbui@suse.com>2023-01-26 16:07:17 +0100
committerFranck Bui <fbui@suse.com>2023-03-24 14:08:57 +0100
commit26c2b30277f5a4c7656b732d2093000ffa895297 (patch)
treee4d144b61137d652ec3c46e3219fb4931232effe /meson.build
parentf461a28da70320473c7466bcdc34fa601da0877b (diff)
downloadsystemd-26c2b30277f5a4c7656b732d2093000ffa895297.tar.gz
test: install unit tests in a dedicated subdirectory below '$testsdir'
/usr/lib/systemd/tests may contain more than the unit tests. For example on SUSE we also install the integration tests there. Putting the unit tests in a dedicated directory named 'unit-tests' makes the layout cleaner. Note that `run-unit-tests.py` has not been moved so we don't need to adjust (Fedora) packaging and users also don't need to descend into the subdirectory.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 6 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 6770deed4f..100bf54506 100644
--- a/meson.build
+++ b/meson.build
@@ -201,6 +201,7 @@ kernelinstalldir = kerneldir / 'install.d'
factorydir = datadir / 'factory'
bootlibdir = prefixdir / 'lib/systemd/boot/efi'
testsdir = prefixdir / 'lib/systemd/tests'
+unittestsdir = testsdir / 'unit-tests'
systemdstatedir = localstatedir / 'lib/systemd'
catalogstatedir = systemdstatedir / 'catalog'
randomseeddir = localstatedir / 'lib/systemd'
@@ -4330,7 +4331,7 @@ foreach test : tests
build_by_default : want_tests != 'false',
install_rpath : rootpkglibdir,
install : install_tests,
- install_dir : testsdir / type,
+ install_dir : unittestsdir / type,
link_depends : runtest_env)
if type == 'manual'
@@ -4354,7 +4355,7 @@ exe = executable(
dependencies : userspace,
build_by_default : want_tests != 'false',
install : install_tests,
- install_dir : testsdir)
+ install_dir : unittestsdir)
if want_tests != 'false'
test('test-libsystemd-sym', exe)
endif
@@ -4372,7 +4373,7 @@ exe = executable(
],
build_by_default : want_tests != 'false' and static_libsystemd_pic,
install : install_tests and static_libsystemd_pic,
- install_dir : testsdir)
+ install_dir : unittestsdir)
if want_tests != 'false' and static_libsystemd_pic
test('test-libsystemd-static-sym', exe)
endif
@@ -4386,7 +4387,7 @@ exe = executable(
dependencies : userspace,
build_by_default : want_tests != 'false',
install : install_tests,
- install_dir : testsdir)
+ install_dir : unittestsdir)
if want_tests != 'false'
test('test-libudev-sym', exe)
endif
@@ -4400,7 +4401,7 @@ exe = executable(
dependencies : userspace,
build_by_default : want_tests != 'false' and static_libudev_pic,
install : install_tests and static_libudev_pic,
- install_dir : testsdir)
+ install_dir : unittestsdir)
if want_tests != 'false' and static_libudev_pic
test('test-libudev-static-sym', exe)
endif