summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2023-02-06 09:46:55 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2023-02-06 12:09:55 +0100
commit31560245321b239b041b65caa26777a3f34587be (patch)
treeff3807fdf836ecadd3e1eed0a569fd2476e5e175 /meson.build
parentfc5688375c76a1e367ddb1f5b51603f1f2b4d081 (diff)
downloadsystemd-31560245321b239b041b65caa26777a3f34587be.tar.gz
meson: enable -Wzero-length-bounds
This will warn if fake flexible arrays are re-introduced. I'm not using -Werror=… because we may still get warnings when compiling against old kernel headers. We can crank this up to error later.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d1e39c8a5a..bfc86857d6 100644
--- a/meson.build
+++ b/meson.build
@@ -389,6 +389,7 @@ possible_common_cc_flags = [
'-Wsuggest-attribute=noreturn',
'-Wunused-function',
'-Wwrite-strings',
+ '-Wzero-length-bounds',
# negative arguments are correctly detected starting with meson 0.46.
'-Wno-error=#warnings', # clang