summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Janssen <medhefgo@web.de>2023-02-28 18:05:18 +0100
committerJan Janssen <medhefgo@web.de>2023-03-10 11:41:08 +0100
commit31ffb6b183bafb4c005ba86bf10f961e07e42e0c (patch)
tree572ddbec2418fdc1bba0f882b044fe5f02058c1a /meson.build
parentc4ad9b23cafd67e87abbcdcb186db470a5a487e4 (diff)
downloadsystemd-31ffb6b183bafb4c005ba86bf10f961e07e42e0c.tar.gz
boot: Add RISCV32 and LoongArch support
This is completely untested, but should work in theory, as it's just adding a couple defines according to the specs.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 8 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index cde0c88e48..b1521e5937 100644
--- a/meson.build
+++ b/meson.build
@@ -1960,11 +1960,14 @@ python_39 = python.language_version().version_compare('>=3.9')
#####################################################################
efi_arch = {
- 'aarch64' : 'aa64',
- 'arm' : 'arm',
- 'riscv64' : 'riscv64',
- 'x86_64' : 'x64',
- 'x86' : 'ia32',
+ 'aarch64' : 'aa64',
+ 'arm' : 'arm',
+ 'loongarch32' : 'loongarch32',
+ 'loongarch64' : 'loongarch64',
+ 'riscv32' : 'riscv32',
+ 'riscv64' : 'riscv64',
+ 'x86_64' : 'x64',
+ 'x86' : 'ia32',
}.get(host_machine.cpu_family(), '')
if get_option('bootloader') != 'false' and efi_arch != ''