summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2022-12-16 18:27:06 +0100
committerLennart Poettering <lennart@poettering.net>2022-12-19 11:43:19 +0100
commit34ea7e02320f6f91c354a5c329eeb29f998dd731 (patch)
tree5d0043ff4b6ed73da2140afe170611bfdbee885c /meson.build
parentcc3254c4462905f9c177dfd40dc0c296e00d00df (diff)
downloadsystemd-34ea7e02320f6f91c354a5c329eeb29f998dd731.tar.gz
bootctl: let's start splitting up bootctl like we did for systemctl and others
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 3c6734b578..f0b7b8958e 100644
--- a/meson.build
+++ b/meson.build
@@ -2605,7 +2605,9 @@ if conf.get('HAVE_BLKID') == 1 and conf.get('HAVE_GNU_EFI') == 1
exe = executable(
'bootctl',
- 'src/boot/bootctl.c',
+ ['src/boot/bootctl.c',
+ 'src/boot/bootctl-reboot-to-firmware.c',
+ 'src/boot/bootctl-reboot-to-firmware.h'],
include_directories : includes,
link_with : [boot_link_with],
dependencies : [libblkid,