summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-11-12 15:38:19 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2019-11-13 22:34:14 +0100
commit3602ca6f0c6c7b79458ab80184b4af5334f3a843 (patch)
treeb90f4c4ace6cc5abb78c80e96cf998fd973e5089 /meson.build
parent9e9dd3e329a69a3aad5698552697b3257fdc3845 (diff)
downloadsystemd-3602ca6f0c6c7b79458ab80184b4af5334f3a843.tar.gz
meson: make user $PATH configurable
This partially reverts db11487d1062655f17db54c4d710653f16c87313 (the logic to calculate the correct value is removed, we always use the same setting as for the system manager). Distributions have an easy mechanism to override this if they wish. I think making this configurable is better, because different distros clearly want different defaults here, and making this configurable is nice and clean. If we don't make it configurable, distros which either have to carry patches, or what would be worse, rely on some other configuration mechanism, like /etc/profile. Those other solutions do not apply everywhere (they usually require the shell to be used at some point), so it is better if we provide a nice way to override the default. Fixes #13469.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 56b7bfea70..403705a6b1 100644
--- a/meson.build
+++ b/meson.build
@@ -824,6 +824,11 @@ conf.set10('ENABLE_DEBUG_SIPHASH', enable_debug_siphash)
conf.set10('VALGRIND', get_option('valgrind'))
conf.set10('LOG_TRACE', get_option('log-trace'))
+default_user_path = get_option('user-path')
+if default_user_path != ''
+ conf.set_quoted('DEFAULT_USER_PATH', default_user_path)
+endif
+
#####################################################################
threads = dependency('threads')
@@ -3119,6 +3124,8 @@ status = [
'default net.naming-scheme setting: @0@'.format(default_net_naming_scheme),
'default KillUserProcesses setting: @0@'.format(kill_user_processes),
'default locale: @0@'.format(default_locale),
+ 'default user $PATH: @0@'.format(
+ default_user_path != '' ? default_user_path : '(same as system services)'),
'systemd service watchdog: @0@'.format(watchdog_opt)]
alt_dns_servers = '\n '.join(dns_servers.split(' '))