summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-10-27 08:31:30 +0200
committerLuca Boccassi <luca.boccassi@gmail.com>2022-10-31 21:12:55 +0100
commit3c3e14a7d88e45ba18b4536519e86a1a55877b53 (patch)
treefb52916a05815c854937b3e158836034225b6115 /meson.build
parent04b2541000c0071c7e538dee42759b99562446b7 (diff)
downloadsystemd-3c3e14a7d88e45ba18b4536519e86a1a55877b53.tar.gz
meson: systemd-repart.standalone
Repart is growing into an important tool on its own, and users might want to install newer versions on systems that have older systemd. Let's make this easier by providing a standalone binary. Related to https://github.com/systemd/mkosi/issues/1228.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 19 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f6db755909..6b7fbc7051 100644
--- a/meson.build
+++ b/meson.build
@@ -3706,6 +3706,25 @@ if conf.get('ENABLE_REPART') == 1
install : true,
install_dir : rootbindir)
public_programs += exe
+
+ if have_standalone_binaries
+ exe = executable(
+ 'systemd-repart.standalone',
+ systemd_repart_sources,
+ include_directories : includes,
+ c_args : '-DSTANDALONE',
+ link_with : [libshared_static,
+ libbasic,
+ libbasic_gcrypt,
+ libsystemd_static],
+ dependencies : [threads,
+ libblkid,
+ libfdisk,
+ libopenssl],
+ install_rpath : rootpkglibdir,
+ install : true,
+ install_dir : rootbindir)
+ endif
endif
executable(