summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaan De Meyer <daan.j.demeyer@gmail.com>2022-10-09 20:46:59 +0200
committerDaan De Meyer <daan.j.demeyer@gmail.com>2022-11-15 20:07:54 +0100
commit48a09a8fff480aab9a68e95e95cc37f6b1438751 (patch)
treee6fcc7e9f49fd5c37ed9b73f2e885415336234c3 /meson.build
parent98e0456ec04c2b210291f41f6d8f8527263e0c67 (diff)
downloadsystemd-48a09a8fff480aab9a68e95e95cc37f6b1438751.tar.gz
repart: Do offline encryption instead of online
Offline encryption can be done without mounting the luks device. For now we still use loop devices to split out the partition we want to write to but in a later commit we'll replace this with a regular file. For offline encryption, we need to keep 2x the luks header size space free at the end of the partition, so this means our encrypted partitions will be 16M larger than before.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 2d41ff8799..55ed968798 100644
--- a/meson.build
+++ b/meson.build
@@ -1325,7 +1325,10 @@ if want_libcryptsetup != 'false' and not skip_deps
foreach ident : ['crypt_set_metadata_size',
'crypt_activate_by_signed_key',
- 'crypt_token_max']
+ 'crypt_token_max',
+ 'crypt_reencrypt_init_by_passphrase',
+ 'crypt_reencrypt',
+ 'crypt_set_data_offset']
have_ident = have and cc.has_function(
ident,
prefix : '#include <libcryptsetup.h>',