summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJames Hilliard <james.hilliard1@gmail.com>2019-01-05 11:28:59 +0800
committerLennart Poettering <lennart@poettering.net>2019-01-06 13:51:18 +0100
commit50f2fc77d77707728519891b585c315f4ba103c1 (patch)
tree53752148ca8424939aca2750c4617713a8cf7f51 /meson.build
parentd27d60b3bca61684a2b6e14f984e02d8a7ecd15c (diff)
downloadsystemd-50f2fc77d77707728519891b585c315f4ba103c1.tar.gz
Disable tools/choose-default-locale.sh when cross compiling
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 6 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 5dd105f097..2a53065470 100644
--- a/meson.build
+++ b/meson.build
@@ -834,8 +834,12 @@ substs.set('NTP_SERVERS', ntp_servers)
default_locale = get_option('default-locale')
if default_locale == ''
- choose_default_locale_sh = find_program('tools/choose-default-locale.sh')
- default_locale = run_command(choose_default_locale_sh).stdout().strip()
+ if not meson.is_cross_build()
+ choose_default_locale_sh = find_program('tools/choose-default-locale.sh')
+ default_locale = run_command(choose_default_locale_sh).stdout().strip()
+ else
+ default_locale = 'C.UTF-8'
+ endif
endif
conf.set_quoted('SYSTEMD_DEFAULT_LOCALE', default_locale)