summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2022-08-09 14:48:14 +0900
committerLuca Boccassi <luca.boccassi@gmail.com>2022-08-09 20:21:30 +0100
commit53403091d6d6410c651cd5dfcb8caf35082eb571 (patch)
tree45ee6fe543ec2c99e329d40994c1bd4b499448d2 /meson.build
parentff71363c26008a322afe70221dd4b03364b62614 (diff)
downloadsystemd-53403091d6d6410c651cd5dfcb8caf35082eb571.tar.gz
meson: use 'not in'
Follow-ups for 60f97fee2d2f948c8e8963ea8ff767008cb93cae and 32963344736004e01ff4dd9dca079faabaf58cf2.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index cf3aa2b496..a7e3e87744 100644
--- a/meson.build
+++ b/meson.build
@@ -393,7 +393,7 @@ possible_common_cc_flags = [
c_args = get_option('c_args')
# Our json library does not support -ffinite-math-only, which is enabled by -Ofast or -ffast-math.
-if (('-Ofast' in c_args or '-ffast-math' in c_args or '-ffinite-math-only' in c_args) and not ('-fno-finite-math-only' in c_args))
+if (('-Ofast' in c_args or '-ffast-math' in c_args or '-ffinite-math-only' in c_args) and '-fno-finite-math-only' not in c_args)
error('-Ofast, -ffast-math, or -ffinite-math-only is specified in c_args.')
endif