summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorCristian Rodríguez <crodriguez@owncloud.com>2023-01-03 17:52:08 +0000
committerYu Watanabe <watanabe.yu+github@gmail.com>2023-03-06 10:04:39 +0900
commit5545f336fd09148e8d9aa7f83ed19384deaf7a64 (patch)
tree9e450d2cc4de845cfdec4fc0796b024fd090d811 /meson.build
parentefcde781de4ebf7d15410b5d6cb7de3a8c67f6aa (diff)
downloadsystemd-5545f336fd09148e8d9aa7f83ed19384deaf7a64.tar.gz
Include <threads.h> if possible to get thread_local definition
IN C23, thread_local is a reserved keyword and we shall therefore do nothing to redefine it. glibc has it defined for older standard version with the right conditions. v2 by Yu Watanabe: Move the definition to missing_threads.h like the way we define e.g. missing syscalls or missing definitions, and include it by the users. Co-authored-by: Yu Watanabe <watanabe.yu+github@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 5e7cb92a83..a274de5601 100644
--- a/meson.build
+++ b/meson.build
@@ -756,6 +756,7 @@ foreach header : ['crypt.h',
'linux/memfd.h',
'linux/vm_sockets.h',
'sys/auxv.h',
+ 'threads.h',
'valgrind/memcheck.h',
'valgrind/valgrind.h',
'linux/time_types.h',