summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-12-19 22:46:01 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-01-03 12:09:46 +0100
commit568a4ff8b18e58c09b72655a4a3c046a11da08cc (patch)
tree2f2f53cd5f47bc5b736939fa0e4e6ba87b37ddeb /meson.build
parent0c06b50662b94c6805c78193ac4d80875ae33668 (diff)
downloadsystemd-568a4ff8b18e58c09b72655a4a3c046a11da08cc.tar.gz
meson: use a convenience lib for shared resolve files
This reduces the man=false meson target count from 1281 to 1253. -- A fully scientific test: git grep _sources, :/*.build|cut -d: -f2|tr -d ' '|sort|uniq -c reveals that libudev_sources is the only source list now reused twice. There's some ugly circular dependency between libudev and libshared, and anyway I'm not sure if we don't want to use different compilation options (LOG_REALM_…) in those two cases, so I'm leaving that alone for now.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index e73b24dedb..516cc69adc 100644
--- a/meson.build
+++ b/meson.build
@@ -1505,7 +1505,8 @@ if conf.get('ENABLE_RESOLVE') == 1
systemd_resolved_sources,
include_directories : includes,
link_with : [libshared,
- libbasic_gcrypt],
+ libbasic_gcrypt,
+ libsystemd_resolve_core],
dependencies : [threads,
libgpg_error,
libm,
@@ -1518,7 +1519,8 @@ if conf.get('ENABLE_RESOLVE') == 1
systemd_resolve_sources,
include_directories : includes,
link_with : [libshared,
- libbasic_gcrypt],
+ libbasic_gcrypt,
+ libsystemd_resolve_core],
dependencies : [threads,
libgpg_error,
libm,