summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Janssen <medhefgo@web.de>2023-01-27 14:28:15 +0100
committerJan Janssen <medhefgo@web.de>2023-01-27 17:47:09 +0100
commit6249face77359f3ceb1ea4f5cfbab342983b5879 (patch)
tree099339f28449abfe171ecd9a8fa2bd86c9a5b18a /meson.build
parentc8943ce884c3b315aa833a1a9777938719620c6b (diff)
downloadsystemd-6249face77359f3ceb1ea4f5cfbab342983b5879.tar.gz
meson: Remove unused variables
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 3 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 2ca63372bf..e607c5af7c 100644
--- a/meson.build
+++ b/meson.build
@@ -184,7 +184,6 @@ sysctldir = prefixdir / 'lib/sysctl.d'
binfmtdir = prefixdir / 'lib/binfmt.d'
modulesloaddir = prefixdir / 'lib/modules-load.d'
networkdir = rootprefixdir / 'lib/systemd/network'
-pkgincludedir = includedir / 'systemd'
systemgeneratordir = rootlibexecdir / 'system-generators'
usergeneratordir = prefixdir / 'lib/systemd/user-generators'
systemenvgeneratordir = prefixdir / 'lib/systemd/system-environment-generators'
@@ -316,7 +315,6 @@ conf.set10('FIRST_BOOT_FULL_PRESET', get_option('first-
#####################################################################
cc = meson.get_compiler('c')
-pkgconfig = import('pkgconfig')
meson_build_sh = find_program('tools/meson-build.sh')
want_tests = get_option('tests')
@@ -1090,12 +1088,9 @@ else
if clang_found
clang = r.path()
endif
- # Assume that the required flags are supported by the found clang.
- clang_supports_flags = clang_found
else
clang_found = true
clang = cc.cmd_array()
- clang_supports_flags = cc.has_argument('-Wno-compare-distinct-pointer-types')
endif
if clang_found
@@ -2105,7 +2100,7 @@ install_libudev_static = static_library(
if conf.get('HAVE_LIBCRYPTSETUP_PLUGINS') == 1
if conf.get('HAVE_TPM2') == 1
- cryptsetup_token_systemd_tpm2 = shared_library(
+ shared_library(
'cryptsetup-token-systemd-tpm2',
cryptsetup_token_systemd_tpm2_sources,
include_directories : includes,
@@ -2123,7 +2118,7 @@ if conf.get('HAVE_LIBCRYPTSETUP_PLUGINS') == 1
endif
if conf.get('HAVE_LIBFIDO2') == 1
- cryptsetup_token_systemd_fido2 = shared_library(
+ shared_library(
'cryptsetup-token-systemd-fido2',
cryptsetup_token_systemd_fido2_sources,
include_directories : includes,
@@ -2141,7 +2136,7 @@ if conf.get('HAVE_LIBCRYPTSETUP_PLUGINS') == 1
endif
if conf.get('HAVE_P11KIT') == 1
- cryptsetup_token_systemd_pkcs11 = shared_library(
+ shared_library(
'cryptsetup-token-systemd-pkcs11',
cryptsetup_token_systemd_pkcs11_sources,
include_directories : includes,