summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-11-30 09:25:49 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-12-06 10:15:54 +0100
commit6ed3aca5c3bdeeac4bab8825a7356d93c7df3f54 (patch)
tree5f75e4dc581a815574bb27302d1e90a582ce32f2 /meson.build
parent9702d82414047c8ce6ffc52410eae0494ad0bf8e (diff)
downloadsystemd-6ed3aca5c3bdeeac4bab8825a7356d93c7df3f54.tar.gz
meson: build a standalone version of systemd-shutdown
I'd like to use this as a basis for an exitrd: When compiled with -Dstandalone-binaries=true -Db_lto=true -Dbuildtype=release, the new file is 800k. It's more than I'd like, but still quite a bit less than libsystemd-shared.so, which is 3800k.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6ff96da950..08c9c842ab 100644
--- a/meson.build
+++ b/meson.build
@@ -3859,6 +3859,22 @@ executable(
install : true,
install_dir : rootlibexecdir)
+if have_standalone_binaries
+ executable(
+ 'systemd-shutdown.standalone',
+ systemd_shutdown_sources,
+ include_directories : includes,
+ c_args : '-DSTANDALONE',
+ link_with : [libshared_static,
+ libbasic,
+ libsystemd_static],
+ dependencies : [libmount,
+ versiondep],
+ install_rpath : rootpkglibdir,
+ install : true,
+ install_dir : rootlibexecdir)
+endif
+
executable(
'systemd-update-done',
'src/update-done/update-done.c',