summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaan De Meyer <daan.j.demeyer@gmail.com>2022-09-29 12:07:54 +0200
committerDaan De Meyer <daan.j.demeyer@gmail.com>2022-10-07 12:28:09 +0200
commit721620e8a32907ffe546a582c5ac7136b6367510 (patch)
tree8bba81ddeea9557889aa8287828d78bef3252d83 /meson.build
parente81710d3d08886f8957bdbdb6746017ff0538818 (diff)
downloadsystemd-721620e8a32907ffe546a582c5ac7136b6367510.tar.gz
journal: Add --convert= command to journalctl
--convert writes the journal files read by journalctl to the given location. The location should be specified as a full journal file path (e.g. /a/b/c/converted.journal). The directory specifies where the converted journal files will be stored. The filename specifies the naming convention the converted journal files will follow.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 75f5f0f70a..a14bda719a 100644
--- a/meson.build
+++ b/meson.build
@@ -2293,11 +2293,13 @@ public_programs += executable(
install : true)
if get_option('link-journalctl-shared')
- journalctl_link_with = [libshared]
+ journalctl_link_with = [libshared,
+ libjournal_core]
else
journalctl_link_with = [libsystemd_static,
libshared_static,
- libbasic_gcrypt]
+ libbasic_gcrypt,
+ libjournal_core]
endif
public_programs += executable(