summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLudwig Nussel <ludwig.nussel@suse.de>2022-12-08 16:27:31 +0100
committerLudwig Nussel <ludwig.nussel@suse.de>2023-01-19 14:24:43 +0100
commit8702496bfb0205764569782a9a2ebd11fd80e5e8 (patch)
tree1b610c546c1ef4fb3422341430edab09bf5873f3 /meson.build
parent1132fd73b32a06c6349f20c0cfb235cc854a1a3a (diff)
downloadsystemd-8702496bfb0205764569782a9a2ebd11fd80e5e8.tar.gz
bootctl: unlink and cleanup functions
The unlink command removes an entry from the ESP including referenced files that are not referenced in other entries. That is useful eg to have multiple entries that use the same kernel with different options. The cleanup command removes all files that are not referenced by any entry.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d1f3a00691..965b237d23 100644
--- a/meson.build
+++ b/meson.build
@@ -4051,6 +4051,7 @@ public_programs += exe
if want_tests != 'false' and want_kernel_install
test('test-kernel-install',
test_kernel_install_sh,
+ env : test_env,
args : [exe.full_path(), loaderentry_install])
endif