summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDominique Martinet <asmadeus@codewreck.org>2022-09-30 19:25:18 +0900
committerDominique Martinet <asmadeus@codewreck.org>2022-10-06 21:33:55 +0900
commit87e462f71361a47b154865dc14032a27580dd4cb (patch)
tree760dcd2103f2216496d4d442e727306e8418337f /meson.build
parent5a967e28873816806a8f1e7c6c7d1ac28369f8b9 (diff)
downloadsystemd-87e462f71361a47b154865dc14032a27580dd4cb.tar.gz
libbpf: add compat helpers for libbpf down to 0.1.0
- new symbols are available from libbpf 0.6.0 so could be used with libbpf.so.0, but we're sure the old symbols will be there and this simplifies code - detection at runtime should always work, regardless of whether systemd has been compiled with older or newer libbpf and runs with older or newer libbpf
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0b5fdd1737..b543a83761 100644
--- a/meson.build
+++ b/meson.build
@@ -1050,7 +1050,7 @@ want_bpf_framework = get_option('bpf-framework')
bpf_compiler = get_option('bpf-compiler')
bpf_framework_required = want_bpf_framework == 'true'
-libbpf_version_requirement = '>= 0.7.0'
+libbpf_version_requirement = '>= 0.1.0'
if bpf_compiler == 'gcc'
libbpf_version_requirement = '>= 1.0.0'
endif