summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDmitry V. Levin <ldv@strace.io>2023-03-03 08:00:00 +0000
committerDmitry V. Levin <ldv@strace.io>2023-03-08 18:55:40 +0000
commit9382642c409b2bba549a5453abbf1b2e94686171 (patch)
tree9bd73103588b81133a2696d908e84d50ea09bab5 /meson.build
parentf94e9529fe2c7e1e470b5626e220be5ce443928b (diff)
downloadsystemd-9382642c409b2bba549a5453abbf1b2e94686171.tar.gz
meson.build: check udev rules using udevadm verify
Although udev rules are already being checked by rule-syntax-check.py script, also check them using udevadm verify which performs more thorough checks.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ff8706d94c..6885884a00 100644
--- a/meson.build
+++ b/meson.build
@@ -3847,6 +3847,13 @@ udevadm = executable(
install_dir : rootbindir)
public_programs += udevadm
+if want_tests != 'false'
+ test('udev-rules-check',
+ udevadm,
+ suite : 'dist-check',
+ args : ['verify', '--resolve-names=never', all_rules])
+endif
+
if conf.get('ENABLE_REPART') == 1
exe = executable(
'systemd-repart',