summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFrantisek Sumsal <frantisek@sumsal.cz>2023-01-31 21:43:53 +0100
committerLuca Boccassi <luca.boccassi@gmail.com>2023-01-31 23:57:28 +0000
commit9c45bfb2ac10b343cd27aa30f8f37f4d476d92ca (patch)
treeecc03f4becb32fcf40f626ef58ba97a8832f3f71 /meson.build
parent907046282c27ee2ced5e22abb80ed8df2e157baf (diff)
downloadsystemd-9c45bfb2ac10b343cd27aa30f8f37f4d476d92ca.tar.gz
ukify: don't install ukify man page if ukify is not enabled
Checking for gnu-efi is not enough, since ukify can be explicitly disabled. Resolves: #26274
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build29
1 files changed, 15 insertions, 14 deletions
diff --git a/meson.build b/meson.build
index 2ca63372bf..71ebe6716f 100644
--- a/meson.build
+++ b/meson.build
@@ -1940,6 +1940,21 @@ subdir('src/boot/efi')
############################################################
+pymod = import('python')
+python = pymod.find_installation('python3', required : true, modules : ['jinja2'])
+python_39 = python.language_version().version_compare('>=3.9')
+
+if get_option('ukify') == 'auto'
+ want_ukify = python_39 and conf.get('HAVE_GNU_EFI') == 1
+elif get_option('ukify') == 'true' and (not python_39 or conf.get('HAVE_GNU_EFI') != 1)
+ error('ukify requires Python >= 3.9 and GNU EFI')
+else
+ want_ukify = get_option('ukify') == 'true'
+endif
+conf.set10('ENABLE_UKIFY', want_ukify)
+
+############################################################
+#
generate_gperfs = find_program('tools/generate-gperfs.py')
make_autosuspend_rules_py = find_program('tools/make-autosuspend-rules.py')
make_directive_index_py = find_program('tools/make-directive-index.py')
@@ -1971,20 +1986,6 @@ jinja2_cmdline = [meson_render_jinja2, config_h, version_h]
############################################################
-pymod = import('python')
-python = pymod.find_installation('python3', required : true, modules : ['jinja2'])
-python_39 = python.language_version().version_compare('>=3.9')
-
-if get_option('ukify') == 'auto'
- want_ukify = python_39 and conf.get('HAVE_GNU_EFI') == 1
-elif get_option('ukify') == 'true' and (not python_39 or conf.get('HAVE_GNU_EFI') != 1)
- error('ukify requires Python >= 3.9 and GNU EFI')
-else
- want_ukify = get_option('ukify') == 'true'
-endif
-
-############################################################
-
# binaries that have --help and are intended for use by humans,
# usually, but not always, installed in /bin.
public_programs = []