summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2023-03-06 18:25:25 +0100
committerLennart Poettering <lennart@poettering.net>2023-03-06 22:52:20 +0100
commita164d9d5aab40cdcf5685bbfa286d8e08ae76150 (patch)
tree147e1c76881dd705cf42878d31443c974e02cd8c /meson.build
parentdf40b7ef5a1d65e0c1aca1817afed559babb6b4c (diff)
downloadsystemd-a164d9d5aab40cdcf5685bbfa286d8e08ae76150.tar.gz
dissect: implement external helper plugin interface for /bin/mount
With this change we'll install a symlink /sbin/mount.ddi → systemd-dissect. If invoked that way we'll do the equivalent of systemd-dissect --mount. This makes DDIs mountable directly via the "mount" command, by specifying the "-t ddi" pseudo file system type. Moreover you can now mount DDIs directly via /etc/fstab, by specifying "ddi" in the file system column (3rd column).
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a274de5601..ff8706d94c 100644
--- a/meson.build
+++ b/meson.build
@@ -2478,6 +2478,10 @@ if conf.get('HAVE_BLKID') == 1
dependencies : [versiondep],
install_rpath : rootpkglibdir,
install : true)
+
+ meson.add_install_script(meson_make_symlink,
+ bindir / 'systemd-dissect',
+ rootsbindir / 'mount.ddi')
endif
if conf.get('ENABLE_RESOLVE') == 1