summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRobert Scheck <robert@fedoraproject.org>2023-05-14 03:17:47 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2023-05-15 13:30:04 +0200
commitc06d2e440c07756391c527814611a7f5633a12d9 (patch)
treedae14094ef326ef8a351d0e2ef41a61e97948530 /meson.build
parent3dca0b36615b27dd4c6f98204750109c0469bd5c (diff)
downloadsystemd-c06d2e440c07756391c527814611a7f5633a12d9.tar.gz
portable, meson: allow statically linked build
Build option "link-portabled-shared" to build a statically linked systemd-portabled by using -Dlink-portabled-shared=false on systems with full systemd stack except systemd-portabled, such as CentOS/RHEL 9.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 10 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 92ad879f64..91523e81ee 100644
--- a/meson.build
+++ b/meson.build
@@ -2942,11 +2942,18 @@ systemctl = executable(
public_programs += systemctl
if conf.get('ENABLE_PORTABLED') == 1
+ if get_option('link-portabled-shared')
+ portabled_link_with = [libshared]
+ else
+ portabled_link_with = [libsystemd_static,
+ libshared_static]
+ endif
+
dbus_programs += executable(
'systemd-portabled',
systemd_portabled_sources,
include_directories : includes,
- link_with : [libshared],
+ link_with : [portabled_link_with],
dependencies : [libselinux,
threads,
userspace,
@@ -2959,7 +2966,7 @@ if conf.get('ENABLE_PORTABLED') == 1
'portablectl',
'src/portable/portablectl.c',
include_directories : includes,
- link_with : [libshared],
+ link_with : [portabled_link_with],
dependencies : [threads,
userspace,
versiondep],
@@ -4996,6 +5003,7 @@ foreach tuple : [
['link-timesyncd-shared', get_option('link-timesyncd-shared')],
['link-journalctl-shared', get_option('link-journalctl-shared')],
['link-boot-shared', get_option('link-boot-shared')],
+ ['link-portabled-shared', get_option('link-portabled-shared')],
['first-boot-full-preset'],
['fexecve'],
['standalone-binaries', get_option('standalone-binaries')],