summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJan Janssen <medhefgo@web.de>2023-01-27 12:57:35 +0100
committerJan Janssen <medhefgo@web.de>2023-02-21 15:10:26 +0100
commitc12e10d785bfe70359a3ec4ae4666957c570c538 (patch)
tree2b5e6b68fe487a6d542a5b464280a8632a941a8a /meson.build
parent03d319a45f6af7d394a72930ec91e63e5221a4a4 (diff)
downloadsystemd-c12e10d785bfe70359a3ec4ae4666957c570c538.tar.gz
meson: Add simple_tests list
A lot of tests can be defined by just their filename. Moving into their own list keeps things simpler, especially with the next commit. It also makes it easier to keep the lists sorted.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 319246c639..8a397e7c4d 100644
--- a/meson.build
+++ b/meson.build
@@ -1936,6 +1936,7 @@ conf.set10('SYSTEMD_SLOW_TESTS_DEFAULT', slow_tests)
############################################################
tests = []
+simple_tests = []
fuzzers = []
catalogs = []
@@ -4076,6 +4077,10 @@ if '-O2' in c_args and '-flto=auto' in c_args
test_cflags += cc.first_supported_argument('-Wno-maybe-uninitialized')
endif
+foreach test : simple_tests
+ tests += [ [[test]] ]
+endforeach
+
foreach tuple : tests
sources = tuple[0]
link_with = tuple.length() > 1 and tuple[1].length() > 0 ? tuple[1] : [libshared]