summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2023-02-02 02:47:47 +0900
committerYu Watanabe <watanabe.yu+github@gmail.com>2023-03-25 15:27:23 +0900
commitd45cbc071144c5003d2dc35d388790dacad6e6f0 (patch)
tree85760269b9053dfedef9bc6ea230f31f2cb5f953 /meson.build
parent384f22e39f563d15e5902ec23a342ef52d044169 (diff)
downloadsystemd-d45cbc071144c5003d2dc35d388790dacad6e6f0.tar.gz
locale: split out xkbcommon related functions to xkbcommon-util.c
Then, use dlopen_many_sym_or_warn() with DLSYM_ARG() macro.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 3 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index 6770deed4f..b624c6d8f0 100644
--- a/meson.build
+++ b/meson.build
@@ -3181,24 +3181,14 @@ if conf.get('ENABLE_HOSTNAMED') == 1
endif
if conf.get('ENABLE_LOCALED') == 1
- if conf.get('HAVE_XKBCOMMON') == 1
- # logind will load libxkbcommon.so dynamically on its own, but we still
- # need to specify where the headers are
- deps = [libdl,
- libxkbcommon.partial_dependency(compile_args: true),
- userspace,
- versiondep]
- else
- deps = [userspace,
- versiondep]
- endif
-
dbus_programs += executable(
'systemd-localed',
systemd_localed_sources,
include_directories : includes,
link_with : [libshared],
- dependencies : deps,
+ dependencies : libxkbcommon_deps +
+ [userspace,
+ versiondep],
install_rpath : rootpkglibdir,
install : true,
install_dir : rootlibexecdir)