summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorLudwig Nussel <ludwig.nussel@suse.de>2023-01-18 10:25:58 +0100
committerLuca Boccassi <luca.boccassi@gmail.com>2023-01-19 11:42:18 +0000
commitd7efb170688f7704f4406ad6c0ca4cda675bad6a (patch)
tree2df6e0a035b2f29bcf856ab9bd212ba8de1c10c7 /meson.build
parent78d774bab4dd44dadaacf40f190f9706deff4fa5 (diff)
downloadsystemd-d7efb170688f7704f4406ad6c0ca4cda675bad6a.tar.gz
meson: ukify depends on GNU_EFI
ukify is rather efi specific and the manpage is already conditional on HAVE_GNU_EFI so make the program also depend on HAVE_GNU_EFI
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build36
1 files changed, 18 insertions, 18 deletions
diff --git a/meson.build b/meson.build
index 2688c39252..d1f3a00691 100644
--- a/meson.build
+++ b/meson.build
@@ -716,24 +716,6 @@ endif
############################################################
-python = find_program('python3')
-if run_command(python, '-c', 'import jinja2', check : false).returncode() != 0
- error('python3 jinja2 missing')
-endif
-
-python_310 = run_command(python, '-c',
- 'import sys; sys.exit(0 if sys.version_info >= (3,10) else 1)',
- check : false).returncode() == 0
-if get_option('ukify') == 'auto'
- want_ukify = python_310
-elif get_option('ukify') == 'true' and not python310
- error('ukify requires Python >= 3.10')
-else
- want_ukify = get_option('ukify') == 'true'
-endif
-
-############################################################
-
gperf = find_program('gperf')
gperf_test_format = '''
@@ -1989,6 +1971,24 @@ jinja2_cmdline = [meson_render_jinja2, config_h, version_h]
############################################################
+python = find_program('python3')
+if run_command(python, '-c', 'import jinja2', check : false).returncode() != 0
+ error('python3 jinja2 missing')
+endif
+
+python_310 = run_command(python, '-c',
+ 'import sys; sys.exit(0 if sys.version_info >= (3,10) else 1)',
+ check : false).returncode() == 0
+if get_option('ukify') == 'auto'
+ want_ukify = python_310 and conf.get('HAVE_GNU_EFI') == 1
+elif get_option('ukify') == 'true' and (not python310 or conf.get('HAVE_GNU_EFI') != 1)
+ error('ukify requires Python >= 3.10 and GNU EFI')
+else
+ want_ukify = get_option('ukify') == 'true'
+endif
+
+############################################################
+
# binaries that have --help and are intended for use by humans,
# usually, but not always, installed in /bin.
public_programs = []