summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-11-22 14:13:32 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-12-01 18:58:54 +0100
commitd9daae55d5d7d7cfe4edcc70fb120f28d5ba5dc5 (patch)
tree75d3e35082861b28f15ac7716ce62c50feb3e295 /meson.build
parent1a2d4d70845f483bcb3f704fa092f5fd76580d31 (diff)
downloadsystemd-d9daae55d5d7d7cfe4edcc70fb120f28d5ba5dc5.tar.gz
tmpfiles: add a special return code for syntax failures
In this way, individual errors in files can be treated differently than a failure of the whole service. A test is added to check that the expected value is returned. Some parts are commented out, because it is not. This will be fixed in a subsequent commit.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6eff25f45c..6288b5697b 100644
--- a/meson.build
+++ b/meson.build
@@ -2146,6 +2146,11 @@ if conf.get('ENABLE_TMPFILES') == 1
install : true,
install_dir : rootbindir)
public_programs += [exe]
+
+ test('test-systemd-tmpfiles',
+ test_systemd_tmpfiles_py,
+ args : exe.full_path())
+ # https://github.com/mesonbuild/meson/issues/2681
endif
if conf.get('ENABLE_HWDB') == 1