summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-01-27 09:10:25 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-01-27 09:10:25 +0100
commite3c368f63c8ec71ba06e699ff46eb3e0d8e3bb0a (patch)
treeb9b079b7c7fdfe06c581e3c68bfa164e0c62de9e /meson.build
parent4c890ad3cc7b3445683d7b52bc00e4a58bef5e94 (diff)
downloadsystemd-e3c368f63c8ec71ba06e699ff46eb3e0d8e3bb0a.tar.gz
meson: rename target to update-man-rules
Same justification as for update-dbus-docs.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f1de3a87d3..569cac9281 100644
--- a/meson.build
+++ b/meson.build
@@ -3624,6 +3624,15 @@ if dbus_docs.length() > 0
endif
endif
+custom_target(
+ 'update-man-rules',
+ output : 'update-man-rules',
+ command : ['sh', '-c',
+ 'cd @0@ && '.format(meson.build_root()) +
+ 'python3 @0@/tools/update-man-rules.py $(find @0@ -wholename "*/man/*.xml") >t && '.format(project_source_root) +
+ 'mv t @0@/man/rules/meson.build'.format(meson.current_source_dir())],
+ depend_files : custom_entities_ent)
+
############################################################
watchdog_opt = service_watchdog == '' ? 'disabled' : service_watchdog