summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEvgeny Vereshchagin <evvers@ya.ru>2022-01-09 21:52:14 +0000
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-01-10 09:42:38 +0100
commite8635fd370400a74977dcceec20c184235664494 (patch)
treeb357c17efdd68e7aa088fe1477f4bf0f6cc22e25 /meson.build
parent79a67f3ca4d32c37b5e754501852a85eae908a6a (diff)
downloadsystemd-e8635fd370400a74977dcceec20c184235664494.tar.gz
meson: no longer skip dependencies when fuzzers are built locally
to make it easier to fuzz code that uses external libraries like libelf/libdw. The dependencies are skipped on OSS-Fuzz because they aren't available at runtime if they aren't linked statically. This restriction can safely be lifted when the fuzzers are built locally with all the dependencies installed. As far as I know there is at least one fuzz target in the systemd repository that can benefit from this: https://github.com/systemd/systemd/issues/11018
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 24b7ab8fd6..021bcd003c 100644
--- a/meson.build
+++ b/meson.build
@@ -40,7 +40,7 @@ if want_ossfuzz and want_libfuzzer
error('only one of oss-fuzz or llvm-fuzz can be specified')
endif
-skip_deps = want_ossfuzz or want_libfuzzer
+skip_deps = want_ossfuzz
fuzzer_build = want_ossfuzz or want_libfuzzer
# Create a title-less summary section early, so it ends up first in the output.