summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-10 01:47:13 +0100
committerYu Watanabe <watanabe.yu+github@gmail.com>2023-05-10 15:05:18 +0900
commiteb29296937b268e0140a2ab1cf204c2ebb72fa5a (patch)
tree766341c3788cf78e941aac86de7d698a65fda6fc /meson.build
parent8707dcdf3b5b4b01530639389350505fcb700969 (diff)
downloadsystemd-eb29296937b268e0140a2ab1cf204c2ebb72fa5a.tar.gz
dirent: conditionalize dirent assert based on dirent64 existence
>=musl-1.2.4 doesn't define dirent64 and its LFS friends as its "native" functions are already LFS-aware. Check for dirent64 in meson.build and only assert if it exists. Bug: https://bugs.gentoo.org/905900 Closes: https://github.com/systemd/systemd/pull/25809
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f6c7279fd5..92ad879f64 100644
--- a/meson.build
+++ b/meson.build
@@ -544,6 +544,7 @@ assert(long_max > 100000)
conf.set_quoted('LONG_MAX_STR', '@0@'.format(long_max))
decl_headers = '''
+#include <dirent.h>
#include <uchar.h>
#include <sys/mount.h>
#include <sys/stat.h>
@@ -553,6 +554,7 @@ foreach decl : ['char16_t',
'char32_t',
'struct mount_attr',
'struct statx',
+ 'struct dirent64',
]
# We get -1 if the size cannot be determined