summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMike Yuan <me@yhndnzj.com>2023-01-18 01:21:59 +0800
committerLuca Boccassi <luca.boccassi@gmail.com>2023-02-15 20:00:51 +0000
commitf129d0e77c4c9a0e12ae38cd241cd49846844a80 (patch)
tree6518a9c10e5f4697ac1ab47e668330bcfa780ba9 /meson.build
parent0688bea1631c9ddb83cbfadfe7e0bb66ffc3e17a (diff)
downloadsystemd-f129d0e77c4c9a0e12ae38cd241cd49846844a80.tar.gz
vconsole: allow setting default keymap through build option
Allow defining the default keymap to be used by vconsole-setup through a build option. A template vconsole.conf also gets populated by tmpfiles if it doesn't exist.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index bfc86857d6..319246c639 100644
--- a/meson.build
+++ b/meson.build
@@ -985,6 +985,9 @@ conf.set_quoted('SYSTEMD_DEFAULT_LOCALE', default_locale)
nspawn_locale = get_option('nspawn-locale')
conf.set_quoted('SYSTEMD_NSPAWN_LOCALE', nspawn_locale)
+default_keymap = get_option('default-keymap')
+conf.set_quoted('SYSTEMD_DEFAULT_KEYMAP', default_keymap)
+
localegen_path = get_option('localegen-path')
if localegen_path != ''
conf.set_quoted('LOCALEGEN_PATH', localegen_path)