summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2023-04-13 18:11:39 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2023-05-05 18:42:37 +0200
commitf9a6cb0e138ddeeebe767b2632a35fa933e53c5f (patch)
tree9be926186f19d49429939368d93381b10e978b1b /meson.build
parentca1abaa5c4ffbd0f72f5bbbd98a70db925a82503 (diff)
downloadsystemd-f9a6cb0e138ddeeebe767b2632a35fa933e53c5f.tar.gz
test-kernel-install: test 60-ukify.install and 90-uki-copy.install
We install a kernel with layout=uki and uki_generator=ukify, and test that a UKI gets installed in the expected place. The two plugins cooperate, so it's easiest to test them together.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 15 insertions, 10 deletions
diff --git a/meson.build b/meson.build
index 88ef5679c5..910b55d3c0 100644
--- a/meson.build
+++ b/meson.build
@@ -4352,7 +4352,7 @@ executable(
install : true,
install_dir : rootlibexecdir)
-exe = custom_target(
+kernel_install = custom_target(
'kernel-install',
input : kernel_install_in,
output : 'kernel-install',
@@ -4364,14 +4364,7 @@ if want_kernel_install
public_programs += exe
endif
-if want_tests != 'false' and want_kernel_install
- test('test-kernel-install',
- test_kernel_install_sh,
- env : test_env,
- args : [exe.full_path(), loaderentry_install])
-endif
-
-exe = custom_target(
+ukify = custom_target(
'ukify',
input : 'src/ukify/ukify.py',
output : 'ukify',
@@ -4380,7 +4373,19 @@ exe = custom_target(
install_mode : 'rwxr-xr-x',
install_dir : rootlibexecdir)
if want_ukify
- public_programs += exe
+ public_programs += ukify
+endif
+
+if want_tests != 'false' and want_kernel_install
+ args = [kernel_install.full_path(), loaderentry_install, uki_copy_install]
+ if want_ukify
+ args += [ukify.full_path(), ukify_install]
+ endif
+
+ test('test-kernel-install',
+ test_kernel_install_sh,
+ env : test_env,
+ args : args)
endif
############################################################