summaryrefslogtreecommitdiff
path: root/shell-completion/bash/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2021-05-16 18:34:23 +0200
committerYu Watanabe <watanabe.yu+github@gmail.com>2021-05-19 10:25:26 +0900
commit5908656c5737bf900b9c6826b45b4e0d43fc9577 (patch)
tree0928124c3e02a504b6435b846522fd2610813112 /shell-completion/bash/meson.build
parent8f127e161e59b874788bd5f68cda77023a4145cd (diff)
downloadsystemd-5908656c5737bf900b9c6826b45b4e0d43fc9577.tar.gz
meson: use jinja2 in shell-completion/
Diffstat (limited to 'shell-completion/bash/meson.build')
-rw-r--r--shell-completion/bash/meson.build80
1 files changed, 40 insertions, 40 deletions
diff --git a/shell-completion/bash/meson.build b/shell-completion/bash/meson.build
index 1afa7977e6..c26b413d92 100644
--- a/shell-completion/bash/meson.build
+++ b/shell-completion/bash/meson.build
@@ -10,45 +10,45 @@ if bashcompletiondir == ''
endif
endif
-if bashcompletiondir != 'no'
- bash_systemctl = configure_file(
- input : 'systemctl.in',
- output : 'systemctl',
- configuration : substs)
+custom_target(
+ 'systemctl',
+ input : 'systemctl.in',
+ output : 'systemctl',
+ command : [meson_render_jinja2, config_h, '@INPUT@'],
+ capture : true,
+ install : bashcompletiondir != 'no',
+ install_dir : bashcompletiondir)
- items = [['busctl', ''],
- ['journalctl', ''],
- ['systemd-analyze', ''],
- ['systemd-cat', ''],
- ['systemd-cgls', ''],
- ['systemd-cgtop', ''],
- ['systemd-delta', ''],
- ['systemd-detect-virt', ''],
- ['systemd-id128', ''],
- ['systemd-nspawn', ''],
- ['systemd-path', ''],
- ['systemd-run', ''],
- ['udevadm', ''],
- ['kernel-install', ''],
- [bash_systemctl, ''],
- ['bootctl', 'ENABLE_EFI'],
- ['coredumpctl', 'ENABLE_COREDUMP'],
- ['homectl', 'ENABLE_HOMED'],
- ['hostnamectl', 'ENABLE_HOSTNAMED'],
- ['localectl', 'ENABLE_LOCALED'],
- ['loginctl', 'ENABLE_LOGIND'],
- ['machinectl', 'ENABLE_MACHINED'],
- ['networkctl', 'ENABLE_NETWORKD'],
- ['portablectl', 'ENABLE_PORTABLED'],
- ['resolvectl', 'ENABLE_RESOLVE'],
- ['systemd-resolve', 'ENABLE_RESOLVE'],
- ['timedatectl', 'ENABLE_TIMEDATED'],
- ]
+items = [['busctl', ''],
+ ['journalctl', ''],
+ ['systemd-analyze', ''],
+ ['systemd-cat', ''],
+ ['systemd-cgls', ''],
+ ['systemd-cgtop', ''],
+ ['systemd-delta', ''],
+ ['systemd-detect-virt', ''],
+ ['systemd-id128', ''],
+ ['systemd-nspawn', ''],
+ ['systemd-path', ''],
+ ['systemd-run', ''],
+ ['udevadm', ''],
+ ['kernel-install', ''],
+ ['bootctl', 'ENABLE_EFI'],
+ ['coredumpctl', 'ENABLE_COREDUMP'],
+ ['homectl', 'ENABLE_HOMED'],
+ ['hostnamectl', 'ENABLE_HOSTNAMED'],
+ ['localectl', 'ENABLE_LOCALED'],
+ ['loginctl', 'ENABLE_LOGIND'],
+ ['machinectl', 'ENABLE_MACHINED'],
+ ['networkctl', 'ENABLE_NETWORKD'],
+ ['portablectl', 'ENABLE_PORTABLED'],
+ ['resolvectl', 'ENABLE_RESOLVE'],
+ ['systemd-resolve', 'ENABLE_RESOLVE'],
+ ['timedatectl', 'ENABLE_TIMEDATED']]
- foreach item : items
- if item[1] == '' or conf.get(item[1]) == 1
- install_data(item[0],
- install_dir : bashcompletiondir)
- endif
- endforeach
-endif
+foreach item : items
+ if bashcompletiondir != 'no' and (item[1] == '' or conf.get(item[1]) == 1)
+ install_data(item[0],
+ install_dir : bashcompletiondir)
+ endif
+endforeach