summaryrefslogtreecommitdiff
path: root/shell-completion/bash/meson.build
diff options
context:
space:
mode:
authorMichael Biebl <mbiebl@gmail.com>2017-04-13 10:30:56 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-23 21:47:28 -0400
commite17e5ba9bff633b5f2b6e9950b3bb64b59079c74 (patch)
tree9444c5744f3f45573c2cc7e10978ef65151147e6 /shell-completion/bash/meson.build
parent082ef2adbddecde5432608298a19551319b162c5 (diff)
downloadsystemd-e17e5ba9bff633b5f2b6e9950b3bb64b59079c74.tar.gz
meson: use join_paths consistently
With -Dsplit-usr=true, we set rootprefix to /. This leads to //lib/systemd or //lib/udev for various dir variables. Using join_paths() avoids this.
Diffstat (limited to 'shell-completion/bash/meson.build')
-rw-r--r--shell-completion/bash/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/shell-completion/bash/meson.build b/shell-completion/bash/meson.build
index bbd705c1cf..07de1d232a 100644
--- a/shell-completion/bash/meson.build
+++ b/shell-completion/bash/meson.build
@@ -6,7 +6,7 @@ if bashcompletiondir == ''
if bash_completion.found()
bashcompletiondir = bash_completion.get_pkgconfig_variable('completionsdir')
else
- bashcompletiondir = datadir + '/bash-completion/completions'
+ bashcompletiondir = join_paths(datadir, 'bash-completion/completions')
endif
message('bash completions: @0@'.format(bashcompletiondir))