summaryrefslogtreecommitdiff
path: root/src/basic/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2023-03-10 09:47:10 +0100
committerLennart Poettering <lennart@poettering.net>2023-03-10 09:47:39 +0100
commit4870133bfaaf97189a970a29bf47e0e38fa721aa (patch)
treed2fa9a5699a8b4c948179afabf3da2f9da322ce5 /src/basic/meson.build
parent5f64d2bf332371bdfdcb91b588e57d4c0c20428f (diff)
downloadsystemd-4870133bfaaf97189a970a29bf47e0e38fa721aa.tar.gz
basic: add RuntimeScope enum
In various tools and services we have a per-system and per-user concept. So far we sometimes used a boolean indicating whether we are in system mode, or a reversed boolean indicating whether we are in user mode, or the LookupScope enum used by the lookup path logic. Let's address that, in introduce a common enum for this, we can use all across the board. This is mostly just search/replace, no actual code changes.
Diffstat (limited to 'src/basic/meson.build')
-rw-r--r--src/basic/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/basic/meson.build b/src/basic/meson.build
index b9da0544c2..98b4d0ee95 100644
--- a/src/basic/meson.build
+++ b/src/basic/meson.build
@@ -71,6 +71,7 @@ basic_sources = files(
'recurse-dir.c',
'replace-var.c',
'rlimit-util.c',
+ 'runtime-scope.c',
'sigbus.c',
'signal-util.c',
'siphash24.c',