summaryrefslogtreecommitdiff
path: root/src/basic/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-12-20 20:35:25 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-12-21 13:43:20 +0100
commit681bd2c524ed71ac04045c90884ba8d55eee7b66 (patch)
treef50b21fb487cead9833a04a307f0e4d7b54d7a8d /src/basic/meson.build
parentb9da6a098b08d4eafec239fc05e0fd2073115504 (diff)
downloadsystemd-681bd2c524ed71ac04045c90884ba8d55eee7b66.tar.gz
meson: generate version tag from git
$ build/systemctl --version systemd 239-3555-g6178cbb5b5 +PAM +AUDIT +SELINUX +IMA -APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN +PCRE2 default-hierarchy=hybrid $ git tag v240 -m 'v240' $ ninja -C build ninja: Entering directory `build' [76/76] Linking target fuzz-unit-file. $ build/systemctl --version systemd 240 +PAM +AUDIT +SELINUX +IMA -APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD -IDN2 +IDN +PCRE2 default-hierarchy=hybrid This is very useful during development, because a precise version string is embedded in the build product and displayed during boot, so we don't have to guess answers for questions like "did I just boot the latest version or the one from before?". This change creates an overhead for "noop" builds. On my laptop, 'ninja -C build' that does nothing goes from 0.1 to 0.5 s. It would be nice to avoid this, but I think that <1 s is still acceptable. Fixes #7183. PACKAGE_VERSION is renamed to GIT_VERSION, to make it obvious that this is the more dynamically changing version string. Why save to a file? It would be easy to generate the version tag using run_command(), but we want to go through a file so that stuff gets rebuilt when this file changes. If we just defined an variable in meson, ninja wouldn't know it needs to rebuild things.
Diffstat (limited to 'src/basic/meson.build')
-rw-r--r--src/basic/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/basic/meson.build b/src/basic/meson.build
index 23b5e75bd8..95a0d45450 100644
--- a/src/basic/meson.build
+++ b/src/basic/meson.build
@@ -1,5 +1,10 @@
# SPDX-License-Identifier: LGPL-2.1+
+version_h = vcs_tag(
+ command: vcs_tagger,
+ input : 'version.h.in',
+ output : 'version.h')
+
basic_sources = files('''
MurmurHash2.c
MurmurHash2.h