summaryrefslogtreecommitdiff
path: root/src/core/meson.build
diff options
context:
space:
mode:
authorJulia Kartseva <hex@fb.com>2021-04-19 23:30:08 -0700
committerJulia Kartseva <hex@fb.com>2021-04-26 16:21:59 -0700
commit09fc220c52fad8fdc8648ab5b8162b822b6565b6 (patch)
tree9a1747de8767466f0159ed64aeb8f044494a2065 /src/core/meson.build
parent7d861e12637892f1fcf7bbd69e4aec5a096f4bcb (diff)
downloadsystemd-09fc220c52fad8fdc8648ab5b8162b822b6565b6.tar.gz
meson, bpf: add build rule for socket-bind program
Diffstat (limited to 'src/core/meson.build')
-rw-r--r--src/core/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/core/meson.build b/src/core/meson.build
index a1294f3a72..f8027333a9 100644
--- a/src/core/meson.build
+++ b/src/core/meson.build
@@ -123,6 +123,11 @@ libcore_sources = '''
unit.h
'''.split()
+subdir('bpf/socket_bind')
+if conf.get('BPF_FRAMEWORK') == 1
+ libcore_sources += [socket_bind_skel_h]
+endif
+
load_fragment_gperf_gperf = custom_target(
'load-fragment-gperf.gperf',
input : 'load-fragment-gperf.gperf.m4',