summaryrefslogtreecommitdiff
path: root/src/core/meson.build
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2022-06-01 08:23:02 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-06-07 10:04:43 +0200
commit5fb225615bf751b97644bed7aae44f69ba03cc84 (patch)
tree803ef39853997e64e9e7dd56d73b607efed345bb /src/core/meson.build
parent3cf63830acdef9d8afdc9ef1cf25aa7e85a5e4d5 (diff)
downloadsystemd-5fb225615bf751b97644bed7aae44f69ba03cc84.tar.gz
meson: install libsystemd-shared into rootpkglibdir
Introduce rootpkglibdir for installing libsystemd-{shared,core}.so. The benefit over using rootlibexecdir is that this path can be multiarch aware, i.e. this path can be architecture qualified. This is something we'd like to make use of in Debian/Ubuntu to make libsystemd-shared co-installable, e.g. for i386 the path would be /usr/lib/i386-linux-gnu/systemd/libsystemd-shared-*.so and for amd64 /usr/lib/x86_64-linux-gnu/systemd/libsystemd-shared-*.so. This will allow for example to install and run systemd-boot/i386 on an amd64 host. It also simplifies/enables cross-building/bootstrapping. For more infos about Multi-Arch see https://wiki.debian.org/Multiarch. See also https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=990547
Diffstat (limited to 'src/core/meson.build')
-rw-r--r--src/core/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/core/meson.build b/src/core/meson.build
index d7ac4e59a8..ac4b8d374c 100644
--- a/src/core/meson.build
+++ b/src/core/meson.build
@@ -202,7 +202,7 @@ libcore = shared_library(
libblkid,
libacl],
install : true,
- install_dir : rootlibexecdir)
+ install_dir : rootpkglibdir)
core_includes = [includes, include_directories('.')]