summaryrefslogtreecommitdiff
path: root/src/core/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-04-05 16:52:44 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-04-05 22:18:31 +0200
commit8f04a1ca2bf973e5419c32adca1dcf888e0b263f (patch)
tree978baef3c11ea9c87119843b155a47618e5377ca /src/core/meson.build
parent3761002eeaead8392a1c1517251c4f9be7c688aa (diff)
downloadsystemd-8f04a1ca2bf973e5419c32adca1dcf888e0b263f.tar.gz
meson: also allow setting GIT_VERSION via templates
GIT_VERSION is not available as a config.h variable, because it's rendered into version.h during builds. Let's rework jinja2 rendering to also parse version.h. No functional change, the new variable is so far unused. I guess this will make partial rebuilds a bit slower, but it's useful to be able to use the full version string.
Diffstat (limited to 'src/core/meson.build')
-rw-r--r--src/core/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/core/meson.build b/src/core/meson.build
index f5e04b37ca..ee2f8774bf 100644
--- a/src/core/meson.build
+++ b/src/core/meson.build
@@ -151,7 +151,7 @@ load_fragment_gperf_gperf = custom_target(
'load-fragment-gperf.gperf',
input : 'load-fragment-gperf.gperf.in',
output: 'load-fragment-gperf.gperf',
- command : [meson_render_jinja2, config_h, '@INPUT@', '@OUTPUT@'])
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'])
load_fragment_gperf_c = custom_target(
'load-fragment-gperf.c',
@@ -217,7 +217,7 @@ foreach item : in_files
file,
input : file + '.in',
output: file,
- command : [meson_render_jinja2, config_h, '@INPUT@', '@OUTPUT@'],
+ command : [jinja2_cmdline, '@INPUT@', '@OUTPUT@'],
install : (dir == pkgsysconfdir) ? install_sysconfdir_samples : (dir != 'no'),
install_dir : dir)
endforeach