summaryrefslogtreecommitdiff
path: root/src/fundamental/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2021-11-09 23:54:10 +0100
committerLennart Poettering <lennart@poettering.net>2021-11-11 17:22:31 +0100
commit18fde343a845a909260e3443f0a0734ba00cabe0 (patch)
tree96f198230e660caae4d7183c3e62499d5773c438 /src/fundamental/meson.build
parent31f7765762105f82eacecfc6f510dc68b070fef7 (diff)
downloadsystemd-18fde343a845a909260e3443f0a0734ba00cabe0.tar.gz
boot: clean up unified boot loader entry name/version extraction
Let's make sure IMAGE_ID/IMAGE_VERSION are properly honoured, and explain in a long comment why. Let's also use ID= field again, which was lost by accident. (While we are at it do some minimal OOM checks wherever we touch something)
Diffstat (limited to 'src/fundamental/meson.build')
-rw-r--r--src/fundamental/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/fundamental/meson.build b/src/fundamental/meson.build
index 3c9f07b191..26859653e6 100644
--- a/src/fundamental/meson.build
+++ b/src/fundamental/meson.build
@@ -3,13 +3,15 @@
fundamental_path = meson.current_source_dir()
fundamental_headers = files(
+ 'bootspec-fundamental.h',
'efivars-fundamental.h',
'macro-fundamental.h',
- 'string-util-fundamental.h',
'sha256.h',
+ 'string-util-fundamental.h',
'type.h')
sources = '''
+ bootspec-fundamental.c
efivars-fundamental.c
string-util-fundamental.c
sha256.c