summaryrefslogtreecommitdiff
path: root/src/fundamental/meson.build
diff options
context:
space:
mode:
authorJan Janssen <medhefgo@web.de>2022-01-07 21:55:50 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-01-09 18:02:34 +0100
commitb3c5a7074cd434bc02c4b560afe933d3df24759e (patch)
tree0f81f46c4ff811a10d7d6d2969db13c1d6ecf070 /src/fundamental/meson.build
parentf2d323a3ab8cdbefea9bc0cefb64b12939129d03 (diff)
downloadsystemd-b3c5a7074cd434bc02c4b560afe933d3df24759e.tar.gz
meson: Use files() for source lists for boot and fundamental
This fixes build reproducibility as otherwise the full path of the source files ends up in the output binary.
Diffstat (limited to 'src/fundamental/meson.build')
-rw-r--r--src/fundamental/meson.build22
1 files changed, 9 insertions, 13 deletions
diff --git a/src/fundamental/meson.build b/src/fundamental/meson.build
index 287f0fe36a..f927788c3a 100644
--- a/src/fundamental/meson.build
+++ b/src/fundamental/meson.build
@@ -8,20 +8,16 @@ fundamental_headers = files(
'macro-fundamental.h',
'sha256.h',
'string-util-fundamental.h',
- 'types-fundamental.h')
-
-sources = '''
- bootspec-fundamental.c
- efivars-fundamental.c
- string-util-fundamental.c
- sha256.c
-'''.split()
+ 'types-fundamental.h',
+)
# for sd-boot
-fundamental_source_paths = []
-foreach source : sources
- fundamental_source_paths += meson.current_source_dir() / source
-endforeach
+fundamental_source_paths = files(
+ 'bootspec-fundamental.c',
+ 'efivars-fundamental.c',
+ 'sha256.c',
+ 'string-util-fundamental.c',
+)
# for libbasic
-fundamental_sources = files(sources) + fundamental_headers
+fundamental_sources = fundamental_source_paths + fundamental_headers