summaryrefslogtreecommitdiff
path: root/src/fundamental/meson.build
diff options
context:
space:
mode:
authorJan Janssen <medhefgo@web.de>2023-02-26 14:09:44 +0100
committerJan Janssen <medhefgo@web.de>2023-03-10 11:41:03 +0100
commitdfca5587cf2032f9ad06041b93b0da5cb39b9989 (patch)
tree3998aae5fc6aeea7631dc27aa7fc64310fdc68fa /src/fundamental/meson.build
parent92148283131474116ed458dbc5966d4b8381e1b3 (diff)
downloadsystemd-dfca5587cf2032f9ad06041b93b0da5cb39b9989.tar.gz
tree-wide: Drop gnu-efi
This drops all mentions of gnu-efi and its manual build machinery. A future commit will bring bootloader builds back. A new bootloader meson option is now used to control whether to build sd-boot and its userspace tooling.
Diffstat (limited to 'src/fundamental/meson.build')
-rw-r--r--src/fundamental/meson.build18
1 files changed, 2 insertions, 16 deletions
diff --git a/src/fundamental/meson.build b/src/fundamental/meson.build
index 4b8e32337d..a55a5faa53 100644
--- a/src/fundamental/meson.build
+++ b/src/fundamental/meson.build
@@ -1,25 +1,11 @@
# SPDX-License-Identifier: LGPL-2.1-or-later
-fundamental_path = meson.current_source_dir()
+fundamental_include = include_directories('.')
-fundamental_headers = files(
- 'bootspec-fundamental.h',
- 'efivars-fundamental.h',
- 'macro-fundamental.h',
- 'memory-util-fundamental.h',
- 'sha256.h',
- 'string-util-fundamental.h',
- 'tpm-pcr.h',
-)
-
-# for sd-boot
-fundamental_source_paths = files(
+fundamental_sources = files(
'bootspec-fundamental.c',
'efivars-fundamental.c',
'sha256.c',
'string-util-fundamental.c',
'tpm-pcr.c',
)
-
-# for libbasic
-fundamental_sources = fundamental_source_paths + fundamental_headers