summaryrefslogtreecommitdiff
path: root/src/fuzz/meson.build
diff options
context:
space:
mode:
authorFranck Bui <fbui@suse.com>2019-04-30 16:10:13 +0200
committerLennart Poettering <lennart@poettering.net>2019-04-30 19:31:22 +0200
commit9f3f596477ba68d4ece645536586756caea4ae97 (patch)
treee0063990704cdd4400eec6cc267de13dd523bb71 /src/fuzz/meson.build
parent8b803ad6343a318b026da759c2ca48363af9074f (diff)
downloadsystemd-9f3f596477ba68d4ece645536586756caea4ae97.tar.gz
meson: make source files including nspawn-settings.h depend on libseccomp
Since nspawn-settings.h includes seccomp.h, any file that includes nspawn-settings.h should depend on libseccomp so the correct header path where seccomp.h lives is added to the header search paths. It's especially important for distros such as openSUSE where seccomp.h is not shipped in /usr/include but /usr/include/libseccomp. This patch is similar to 8238423095ca54c48d9408a5da13e0325b31e6f6.
Diffstat (limited to 'src/fuzz/meson.build')
-rw-r--r--src/fuzz/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/fuzz/meson.build b/src/fuzz/meson.build
index 0d1ad2b1e1..a6c6db372b 100644
--- a/src/fuzz/meson.build
+++ b/src/fuzz/meson.build
@@ -128,12 +128,12 @@ fuzzers += [
[['src/fuzz/fuzz-nspawn-settings.c'],
[libshared,
libnspawn_core],
- []],
+ [libseccomp]],
[['src/fuzz/fuzz-nspawn-oci.c'],
[libshared,
libnspawn_core],
- []],
+ [libseccomp]],
[['src/fuzz/fuzz-calendarspec.c'],
[libshared],