summaryrefslogtreecommitdiff
path: root/src/home/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2020-05-05 09:57:04 +0200
committerLennart Poettering <lennart@poettering.net>2020-05-07 23:33:09 +0200
commitc76dd733afe04b36cdac16322a07201c5793f2df (patch)
treecae6b783b67849a6a7d1c285e633101f1d210cde /src/home/meson.build
parentc07bf7a4edfa356d0b2dd7758f660624b5b97a06 (diff)
downloadsystemd-c76dd733afe04b36cdac16322a07201c5793f2df.tar.gz
homed: make default storage/file system type configurable in homed.conf
Diffstat (limited to 'src/home/meson.build')
-rw-r--r--src/home/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/home/meson.build b/src/home/meson.build
index eb6da0b696..2c5664aae1 100644
--- a/src/home/meson.build
+++ b/src/home/meson.build
@@ -31,6 +31,8 @@ systemd_homed_sources = files('''
home-util.h
homed-bus.c
homed-bus.h
+ homed-conf.c
+ homed-conf.h
homed-home-bus.c
homed-home-bus.h
homed-home.c
@@ -52,6 +54,14 @@ systemd_homed_sources = files('''
user-record-util.h
'''.split())
+homed_gperf_c = custom_target(
+ 'homed_gperf.c',
+ input : 'homed-gperf.gperf',
+ output : 'homed-gperf.c',
+ command : [gperf, '@INPUT@', '--output-file', '@OUTPUT@'])
+
+systemd_homed_sources += [homed_gperf_c]
+
homectl_sources = files('''
home-util.c
home-util.h
@@ -78,4 +88,7 @@ if conf.get('ENABLE_HOMED') == 1
install_dir : dbussystemservicedir)
install_data('org.freedesktop.home1.policy',
install_dir : polkitpolicydir)
+
+ install_data('homed.conf',
+ install_dir : pkgsysconfdir)
endif